TIP: Pusta strona – docker nginx z php

Zanim zaczenisz grzebać w konfiguracji i stracisz swój czas. Zweryfikuj poprawność właściciela i grupy plików Twojej strony www. Odpowiednio dla kontenera z serwerem www np. nginx i php.

Niepoprawne przypisanie często objawia się komunikatem w logach “[…] forbidden […]”

// zaloguje się, a potem przypisz prawidłowego właściciela i grupę np.:

docker exec -it container_nginx bash
cd /var/www/html
chown -R nginx .

docker exec -it cointainer_php bash
cd /var/www/html
chown -R www-data .

LMS i migracja z MariaDB 5.x do 10.x

W kontekście przejścia z LMS-PLUS 25.x do 26.x i bazy MariaDB wystąpił problem. W trakcie debugowania okazało się, że rozwiązaniem jest aktualizacja MariaDB do wersji 10.x

yum install wget
wget https://downloads.mariadb.com/MariaDB/mariadb_repo_setup
chmod +x mariadb_repo_setup
./mariadb_repo_setup
yum install MariaDB-server
systemctl enable mariadb.service
systemctl start mariadb.service
mysql_upgrade

Zapowiada się kolejny wpisy o migracji z MariaDB do Postgresa.

Mikrotik 2 or more WAN DHCP/PPP failover

Interfaces in this example:

  • WAN1 = ether1 (DHCP CLIENT)
  • WAN2 = ppp-usb-lte (PPP CLIENT)

Netwatch settings:

/tool netwatch
add comment="WAN1 failover" down-script=":log info \"Failover WAN1: DOWN\"\r\
    \n\r\
    \n/ip dhcp-client set [find interface=\"ether1\"] default-route-distance=11\r\
    \n\r\
    \n/ip dhcp-client release ether1\r\
    \n" host=1.1.1.1 interval=10s up-script=":log info \"Failover WAN1: UP\"\r\
    \n\r\
    \n/ip dhcp-client set [find interface=\"ether1\"] default-route-distance=1"
add comment="WAN2 failover" down-script=\
    ":log info \"Failover WAN2: DOWN\"\r\
    \n\r\
    \n/interface ppp-client set [find interface=\"ppp-usb-lte\"] default-route-distance=12\r\
    \n\r\
    \n/interface ppp-client disable ppp-usb-lte\r\
    \n\r\
    \n/interface ppp-client enable ppp-usb-lte" host=1.0.0.1 interval=10s up-script=":log info \"Failover WAN2: UP\"\r\
    \n\r\
    \n/interface ppp-client set [find interface=\"ppp-usb-lte\"] default-route-distance=2"

Firewall filter rules:

/ip firewall filter
add action=drop chain=output comment="Block WAN2 Access to WAN1 Failover" dst-address=1.1.1.1 out-interface=ppp-usb-lte
add action=drop chain=output comment="Block WAN1 Access to WAN2 Failover" dst-address=1.0.0.1 out-interface=ether1

Nowa forma pieniądza jest tuż za rogiem

Top Fiat Currencies by Market Capitalization: https://fiatmarketcap.com/